尧图精选

docker desktop安装es+kibana

🕒 发布时间:2026/9/27 6:52:27 📁 来源:尧图网络
1、确保wsl子系统有4G以上内存我的docker desktop默认只分配了2G内存需要调整分配内存大小。1、在用户目录下新增.wslconfig配置文件# 进入用户目录 cd $env:USERPROFILE# 新建.wslconfig notepad.wslconfig文件内容如下[wsl2]memory8GB# 默认主机内存的50%最多不超过8GB手动写了就覆盖 # processors # 默认主机全部CPU核心不写就是全部 # swap2GB# 默认内存大小的25%最大4GB# localhostforwardingtrue# 默认true# pageReportingtrue#WSL2空闲内存回收默认开启我只配置了内存其余都是默认配置。2、重启子系统# 重启子系统 wsl--shutdown通过 wsl 连接上子系统查看内存是否修改成功# 连接子系统 wsl # 查看剩余内存 free-h结果通过docker compose启动eskibana1、新增compose文件选择一个目录例如C:\Users\sogan\dockercompose\eskibana新增docker-compose.yml。version:3.8services:# es es01:image:docker.elastic.co/elasticsearch/elasticsearch:8.15.0container_name:es01 environment:# 单节点模式-discovery.typesingle-node-ES_JAVA_OPTS-Xms512m-Xmx512m# 密码-ELASTIC_PASSWORD123456-xpack.security.enabledtrue-xpack.security.enrollment.enabledfalse# 关闭ssl-xpack.security.http.ssl.enabledfalse-xpack.security.transport.ssl.enabledfalseports:# 端口映射-9200:9200volumes:-esdata:/usr/share/elasticsearch/data healthcheck:# 心跳检测 test:[CMD-SHELL,curl -f -u elastic:123456 http://localhost:9200/_cluster/health?localtrue]interval:10s timeout:10s retries:10# 设置网络分区 networks:-elastic # kibana kibana:image:docker.elastic.co/kibana/kibana:8.15.0container_name:kib01 environment:# 连接es的配置-ELASTICSEARCH_HOSTShttp://es01:9200-ELASTICSEARCH_USERNAMEkibana_system-ELASTICSEARCH_PASSWORD123456ports:# 端口映射-5601:5601depends_on:es01:condition:service_healthy # 设置网络分区 networks:-elastic volumes:esdata:networks:elastic:单节点启动关闭了ssl。2、启动进入compose 所在目录执行启动。# 启动命令 docker compose up-d首次启动需要拉取镜像注意镜像地址或使用科学上网。3、验证是否启动成功1、浏览器访问http://localhost:9200/出现登录页输入elastic/123456出现json信息证明es启动成功2、浏览器访问http://localhost:5601/查看kibana是否启动成功。以上截图表示启动失败通过观察kin01日志发现设置的kibana_system/123456没有生效有如下报错Kibana 使用kibana_system账号连接 ES但是账号认证失败用户名 / 密码不对。解决步骤进入es容器初始化账号秘密# 进入es01容器 docker exec-it es01 bash # 重置 kibana_system 密码为123456,-i表示自己设置不加则随机生成 bin/elasticsearch-reset-password-u kibana_system-i重置后重新访问kibana控制台注意登录时使用的账号密码是elastic/123456kibana_system 账号只是kibana连接es的账号密码。设置的密码只要不清除es挂载目录就会一直有效删除后需要重新设置。4、关闭容器# 关闭容器添加-v 表示清除挂载目录 docker compose down
上一篇/下一篇内容由系统自动关联 返回资讯列表 →